You are not logged in. (Login)

Early Care Institute (Childcare Management Solutions)

 
Skip Main MenuSkip Certificates Report

Certificates Report

Skip Calendar

Calendar

Sun Mon Tue Wed Thu Fri Sat
          1 2
3 4 5 6 7 8 9
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 Today Tuesday, 26 September 26 27 28 29 30

Equipment Required

Computer
The computer hardware that you should be using include a standard desktop or laptop computer with I ghz or greater processor, 1 gigabyte or greater memory, speakers, headphones or a head set with microphone
. Our platform is designed to work with IBM compatible computers and some Mac computers. The platform does not fully support Android, IPAD and some Apple Mac devices.

Browser and Plug-In Requirements
In order to participate in the courses on this site, the latest versions of the following tools are required.

Please verify that the computer you will be using has high speed Internet access and the availability of these free software programs that integrate with your browser. Internet Explorer, FireFox and Safari are all supported.

Adobe Acrobat .pdf
http://get.adobe.com/reader/?promoid=BUIGO

Adobe Flash .swf
http://get.adobe.com/flashplayer/?promoid=BUIGP

Apple Quicktime .mp4
http://www.apple.com/quicktime/download/

OpenOffice (Office Suite - Similar to Microsoft Office)
http://www.openoffice.org

For technical support email:

support@EarlyCareInstitute.com
Skip Login